Sabtu, 10 Desember 2011

MENGGABUNGKAN 2 ORANG DALAM 1 PHOTO




SETTING ROUTER RIP & NAT DENGAN SERVER WEB

sekedar info dulu ......
DCE dan DTE
Interface serial membutuhkan clock signal untuk mengontrol pewaktuan komunikasi yang dikenal dengan clock rate.
Peralatan Data Communications Equipment (DCE) seperti modem, atau CSU/DSU, menyediakan clock rate.
Secara default, router Cisco adalah peralatan Data Terminal Equipment (DTE).
Artinya router menerima clock rate dari peralatan DCE.
Konfigurasi Interface Serial
  • Tentukan jenis interface dan angka port-nya
  • Berikan deskripsi dari interface tersebut
  • Konfigurasi IP address dan subnet mask –nya
  • Pilih clock rate, apabila dikonfigurasikan sebagai DCE
  • Mengaktifkan interface tersebut 
-----------------------------------------------------------------------------------------------------------------------------
Langsung pada Pengaturan Router
tapi sebelum masuk ke konfigurasi Router lihat dulu bukannya pada Router1 Jalur Serial sudah kepakai, jadi kita harus menambahkan 1 hardware pendukung RC-45 untuk Serial 6/0 agar kita bisa membuat jalur lain.
Menambahkan 1 Ruang Router PT-ROUTER-NM-1S, tapi jangan lupa matikan Router dulu soalnya ntar ga bisa masuk...

ROUTER1

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#in fa0/0
Router(config-if)#ip add 172.16.2.1 255.255.255.240
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#in s2/0
Router(config-if)#ip add 10.10.10.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#exit
Router(config)#in s3/0
Router(config-if)#ip add 20.20.20.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#in s6/0
Router(config-if)#ip add 30.30.30.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial6/0, changed state to down
Router(config-if)#exit
Router(config)#rou RIP
Router(config-router)#network 10.10.10.0
Router(config-router)#network 20.20.20.0
Router(config-router)#network 30.30.30.0
Router(config-router)#network 172.16.0.0
Router(config-router)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Router#wr mem
Building configuration...
[OK]
Router#
Router#
Router#
Router#sh run
Building configuration...

Current configuration : 736 bytes
!
version 12.2
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 172.16.2.1 255.255.0.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 10.10.10.1 255.0.0.0
 clock rate 64000
!
interface Serial3/0
 ip address 20.20.20.1 255.0.0.0
 clock rate 64000
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
interface Serial6/0
 ip address 30.30.30.1 255.0.0.0
 clock rate 64000
!
router rip
 network 10.0.0.0
 network 20.0.0.0
 network 30.0.0.0
 network 172.16.0.0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end

ROUTER2

Router>en 
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#in fa0/0
Router(config-if)#ip add 200.200.200.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#in s2/0
Router(config-if)#ip add 20.20.20.2 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
Router(config-if)#
Router(config-if)#exit
Router(config)#rou rip
Router(config-router)#network 20.0.0.0
Router(config-router)#network 200.200.200.0
Router(config-router)#no shut
                         ^
% Invalid input detected at '^' marker.
   
Router(config-router)#exit
Router(config)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Router#wr mem
Building configuration...
[OK]
Router#
Router#sh run
Building configuration...

Current configuration : 591 bytes
!
version 12.2
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 200.200.200.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 20.20.20.2 255.0.0.0
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 network 20.0.0.0
 network 200.200.200.0
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end



ROUTER0 NAT

(Kenapa Router 0 kita Set terakhir, karena di Router ini kita menggunakan NAT,inside/outset, dimana kita bisa melakukan jalur masuk ke server/DNS akan tetapi dari DNS/Server tidak bisa masuk ke dalam jaringan kita....
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#in fa0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#in s2/0
Router(config-if)#ip add 10.10.10.2 255.0.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 s2/0
Router(config)#int fa0/0
Router(config-if)#in nat inside
                   ^
% Invalid input detected at '^' marker.
   

Router(config-if)#exit
Router(config)#in s2/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat inside source static 192.168.1.2 10.10.10.3   
Router(config)#no shut                      
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#^Z
Router#wr mem
Building configuration...
[OK]
Router#


SEPERTI Pembahasan sebelumnya..... kita perlu chek apakan Jalur sudah Koneksi,
 dari SERVER ke SERVER Succesfully

 dari Pc ke SERVER Succesfully juga....

Uppssss kenapa dari SERVER ke PC Failed ya..... hehehehe lupa ya.. kan kita setting agar SERVER tidak bisa masuk ke Topologi Jaringan kita.....

jadi... segitu dulu tambahan kita hari ini... saya sedang belajar,semoga bisa lebih mengerti...

Kamis, 08 Desember 2011

SETTING ROUTER RIP (ROUTING INFORMATION PROTOCOL)

Routing Protocol berberda dengan Routed Protocol . Routing Protocol adalah komunikasi antara Router-Router  . Routing Protocol mengijinkan untuk Sharing informasi tentang Jaringan dan Koneksi antar Router . Router menggunakan informasi ini untuk membangun dan memperbaiki table Routingnya

ROUTING INFORMATION PROTOCOL (RIP)
Routed Protocol digunakan untuk user trafik secara langsung. Routed protocol menyediakan informasi yang cukup dalam layer address jaringannya untuk melewati paket yang akan diteruskan dari satu host ke host lain berdasarkan alamatnya. RIP merupakan salah satu protocol routing distance vector yang digunakan untuk ribuan jaringan didunia. Hal ini dikarenakan RIP berdasarkan open standard dan mudah diimplementasikan tetapi RIP membutuhkan daya yang tinggi dan memerlukan fitur router routing protocol. Dasar RIP diterangkan dalam RFC 1058, dengan karakteristik sebagai berikut:
·         Routing Protokol distance vector,
·         Metric berdasarkan pada jumlah lompatan (hop count) untuk pemilihan jalur,
·         Jika hop count lebih dari 15, maka paket dibuang,
·         Update routing dilakukan secara broadcast setain 30 detik.

Dari beberapa RIP ada 2 versi yaitu Versi1 dan Versi 2, namun kali ini kita hanya akan mempelajari Version 2
·         Enhancement dari RIP versi 1 ditambah dangan bebrapa kemampuan baru,
·         Algoritma routing sma dengan RIP versi 1
·         Bedanya terletak pada format dengan tambahan informasi yang dikirim,
·         Kemampuan baru :
o   Tag – untuk rute eksternal,
o   Subnet Mask,
o   Alamat hop berikutnya,
o   Autentikasi.

Dini ada contoh Topologi Jaringan Router menngunakan RIP Version 2 :
buka dulu CISFO Packet Tracer 5.1


1.      Pilih peralatan yang akan dipakai. Agar Sesuai dengan Gambar di atasAtur posisi semua peralatan hingga seperti gambar di atas.
2.      Hubungkan PC dengan Switch menggunakan kabel straigh-Thtough
3.      Hubungkan Switch degan Router menggunakan kabel straigh-Thtough
4.      Hubungkan Router dengan Router menggunakan kabel Serial DCE (lihat contoh)

SETTING

Router0
Fa0/0 10.1.0.1/16
Ser2/0 10.2.0.1/16

Router1
Fa0/0 10.5.0.1/16
Ser2/0 10.2.0.2 DCE/16
Ser3/0 10.3.0.1 DCE/16

Router2
Fa0/0 10.4.0.1/16
Ser2/0 10.3.0.2/16

Subnet Mask 255.255.0.0

SETTING ROUTER0
Router>EN
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#in fa0/0
Router(config-if)#ip add 10.1.0.1 255.255.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#in s2/0
Router(config-if)#ip add 10.2.0.1 255.255.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#exit
Router(config)#rou rip
Router(config-router)#ver 2
Router(config-router)#network 10.1.0.0
Router(config-router)#network 10.2.0.0
Router(config-router)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#sh ip protocol
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 9 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
  Interface             Send  Recv  Triggered RIP  Key-chain
  FastEthernet0/0       2     2    
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
            10.0.0.0
Passive Interface(s):
Routing Information Sources:
            Gateway         Distance      Last Update
Distance: (default is 120)
Router#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/16 is subnetted, 1 subnets
C       10.1.0.0 is directly connected, FastEthernet0/0
Router#^Z
Router#wr mem
Building configuration...
[OK]
Router#

SETTING ROUTER1
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#
Router(config)#
Router(config)#int fa0/0
Router(config-if)#ip add 10.5.0.1 255.255.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#in s2/0
Router(config-if)#ip add 10.2.0.2 255.255.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
Router(config-if)#in s3/0
Router(config-if)#ip add 10.3.0.1 255.255.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#rou rip
Router(config-router)#ver 2
Router(config-router)#network 10.2.0.0
Router(config-router)#network 10.3.0.0
Router(config-router)#network 10.5.0.0
Router(config-router)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#show ip protocol
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 2 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
  Interface             Send  Recv  Triggered RIP  Key-chain
  FastEthernet0/0       2     2    
  Serial2/0             2     2    
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
            10.0.0.0
Passive Interface(s):
Routing Information Sources:
            Gateway         Distance      Last Update
            10.2.0.1             120      00:00:18
Distance: (default is 120)
Router#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/16 is subnetted, 3 subnets
R       10.1.0.0 [120/1] via 10.2.0.1, 00:00:25, Serial2/0
C       10.2.0.0 is directly connected, Serial2/0
C       10.5.0.0 is directly connected, FastEthernet0/0
Router#^Z
Router#wr mem
Building configuration...
[OK]
Router#

SETTING ROUTER2
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#in fa0/0
Router(config-if)#ip add 10.4.0.1 255.255.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#in s2/0
Router(config-if)#ip add 10.3.0.2 255.255.0.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
Router(config-if)#exit
Router(config)#rou rip
Router(config-router)#ver 2
Router(config-router)#network 10.3.0.0
Router(config-router)#network 10.4.0.0
Router(config-router)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#show ip protocol
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 9 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
  Interface             Send  Recv  Triggered RIP  Key-chain
  FastEthernet0/0       2     2    
  Serial2/0             2     2    
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
            10.0.0.0
Passive Interface(s):
Routing Information Sources:
            Gateway         Distance      Last Update
            10.3.0.1             120      00:00:04
Distance: (default is 120)
Router#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/16 is subnetted, 5 subnets
R       10.1.0.0 [120/2] via 10.3.0.1, 00:00:19, Serial2/0
R       10.2.0.0 [120/1] via 10.3.0.1, 00:00:19, Serial2/0
C       10.3.0.0 is directly connected, Serial2/0
C       10.4.0.0 is directly connected, FastEthernet0/0
R       10.5.0.0 [120/1] via 10.3.0.1, 00:00:19, Serial2/0
Router#^Z
Router#wr mem
Building configuration...
[OK]
Router#



BERI IP ADDRESS PADA SETIAP PC

Sebagai berikut :


Setelah semua Router Di Setting dan PC diberi IP ADDRESS, kita bisa chek dengan 2 cara :

Pertama menggunakan ADD SIMPLE PDU (P)

Lakukan pada semua PC dan Router,
Kedua dengan COMMAND PROMP pada Dekstop PC


Lakukan perintah PING (no tujuan IP Address) pada semua PC
Contoh 
PC>ping 10.1.0.4
Pinging 10.1.0.4 with 32 bytes of data:
Reply from 10.1.0.4: bytes=32 time=297ms TTL=128
Reply from 10.1.0.4: bytes=32 time=62ms TTL=128
Reply from 10.1.0.4: bytes=32 time=62ms TTL=128
Reply from 10.1.0.4: bytes=32 time=109ms TTL=128
Ping statistics for 10.1.0.4:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 62ms, Maximum = 297ms, Average = 132ms

Setelah semua Lampu kabel menyala hijau dan pengecekan sambungan dengan ADD SIMPLE PDU / COMMAND PROMP itu menandakan Pekerjaan Kita selesai dengan cara yang benar…


THE RIGHT THINKS
IN THE RIGHT TIME
AT THE RIGHT WAY
GOOD LUCK